Feb 1, 2012

Erro ao conectar banco de dados "ORA-06413: Connection not open"

Boa Noite Pessoal,


Bom, semana passada eu e uma amigo (Renê) "apanhamos" muito para conectar uma aplicação com nhibernate e em um banco de dados Oracle 10g.


Como eu sou muito legal: E o problema era PARÊNTESES "( )", isso mesmo, o client do oracle para .net .


O erro que a aplicação retornava era: 




ORA-06413: Connection not open



Isso quando eu tentava conectar  uma aplicação 32 bits (x86) em uma máquina 64 bits (no caso, windows 2008 64 bits, x64) em uma base de dados oracle 10g

A solução?
Simples: Altere a pasta da aplicação para outra sem parênteses.


Exemplo:

Troque isto:


C:/Arquivos de Programs (x86)/PastaAplicacao


Por isto:




C:/Aplicacoes/PastaAplicacao  --SEM PARÊNTESES


Por hoje é só, espero ter ajudado!


Abraços

Rafael
 



30 comments:

  1. Cara, valeu resolveu um problemão aqui na empresa com esta mesma mensagem.

    ReplyDelete
  2. cara salvou... obrigado...

    ReplyDelete
  3. MANOWW VC EH FODAAAAA.. FIQUEI O DIA INTEIRO TENTANDO CRIAR A CONEXÃO DO DBACCESS DA TOTVS E O ORACLE ... LI DE TUDO E NADA ME AJUDOU.. SUA DICA FOI FUNDAMENTAL.. TIREI A APLICAÇÃO DA PASTA ARQUIVOS DE PROGRAMAS (X86) E JAH ERAS... PQP MLKK VLWW

    ReplyDelete
    Replies
    1. Alterei aqui mas o erro agora é ORA-0107:senha/nome do usuário inválido; logon negado, se mudar o usuário o erro é ORA-28030: O servidor encontrou problemas ao acessar o serviço de diretório LDAP...

      Delete
  4. Obrigado ai manolo;;; salvou geral aki tb

    ReplyDelete
  5. Rafael, a solução funcionou perfeitamente. Muito obrigado!

    ReplyDelete
  6. Alterei aqui mas o erro agora é ORA-0107:senha/nome do usuárioinválido; logon negado, se mudar o usuário o erro é ORA-28030: O servidor encontrou problemas ao acessar o serviço de diretório LDAP...

    ReplyDelete
  7. Rafael, matou a pau!!! obrigado

    ReplyDelete
  8. Cara até hoje o seu post ajuda, quebrou um galhão.

    ReplyDelete
  9. SHOW DE BOLA... SIMPLES E OBJETIVO! Vlw Rafa!!!!

    ReplyDelete
  10. Era exatamente isso, muito obrigado!!

    ReplyDelete
  11. Muito bom.....funcionou perfeitamente

    ReplyDelete
  12. Espetáculo de solução, obrigado!!!

    ReplyDelete
  13. Resolveu de primeira. Obrigado pela dica.

    ReplyDelete
  14. Nossa... também me ajudou. Muito obrigado

    ReplyDelete
  15. cara eu te amo <3 kkkkkkkkk

    ReplyDelete
  16. Valeu pela dica, funcionou.

    ReplyDelete
  17. Cara, tu salvou minha vida. Obrigado Rafael

    ReplyDelete
  18. Amigo top top top a informação ajudou aki muito !!!!

    ReplyDelete
  19. Srs,

    Fiquei na dúvida quanto ao termo "pasta da aplicação", o que seria a mesma ? Pasta do install do oracle ? do Visual Studio ?

    ReplyDelete
  20. No meu caso aqui eu removi o diretório de instalação do software que estava utilizando de C:\Program Files (x86) para C:\Program Files. Simplesmente recortei e colei e deu certo. Fantástico!

    ReplyDelete
  21. muito bom resolve meus problemas de quase 15 dias

    ReplyDelete
  22. Cara, vc continua salvando "vidas"...rs Já não sabia mais o que fazer, quando vi seu post. Muito bom! Valeu mesmo!

    ReplyDelete
  23. Simples e objetivo, excelente dica, resolveu meu problema !!!

    ReplyDelete
  24. Muito bom! Resolveu um "super problema" aqui na empresa!

    ReplyDelete
  25. Rafael, resolveu meu problema... era isto mesmo.
    Parabéns pela dica.
    Obrigado.
    Ass: Alexandre, Itumbiara-GO.

    ReplyDelete